using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(^[^\[\]]*?\])|(\[(?!.*?\]).*)";
string input = @"text [option1/option2] text
text] [option1/option2] more text
text [option1/option2] [text
text] [option1/option2] [text";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}