$re = '/\* \[(\w+)\]\(([\w:\/\.\-\%\&\+]+)\) \[(\w+)\] \*\*([\w\s]+)\*/m';
$str = '* [52e3e](https://gitlab.com/jenkins-code/nancy-jenkins-helm/commit/52e3e) [abc] **Testing Change 1*
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);