package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?:\([^)]*\)(*SKIP)(*FAIL))|, `)
var str = `A, B (one, two), C`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}