use strict;
my $str = '58.189.130.8 NULL-AUTH-USER 1/Jul/2013 03:27:12.818 +0900 GET /newnsmw/webresources/org.nns.entity.tenant/7ab0105f74f0cadbb20ddef606865b1c HTTP/1.1 200 2646
';
my $regex = qr/(0?[1-9]|1[0-2])
\/
(?:Jan|Feb|Mar|Apr|May|Jun|Jul|Aug|Sep|Oct|Nov|Dec)
\/
(1|2)[0-9]{3}
\s
((0|1)[0-9]|2[0-3]):([0-5][0-9]):([0-5][0-9])/xp;
if ( $str =~ /$regex/ ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}