$re = '/(\d+\D*)(?!-)/m';
$str = '-38419-indices-foo-7119-attributes-10073-bar';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);