$re = '/\b(?![a|b]*ab)([a|b])*\b/';
$str = 'aa abba bba';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);