$re = '/^(?:[a-z0-9 %]+|(?:[<>]|>=|<=|!=|%)?[a-z0-9 ]+)$/m';
$str = '>test
!=test
<test
>=test
<=test
%test
test
%test%
test%
<test%
<test<
asdf%';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);