# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"<(?:textarea|select).*?>.*?(\{\{\{variable:(.*?)\}\}\}).*?<\/(?:textarea|select)>|<(?:input).+?(value=.*?)(\{\{\{variable:(.+?)\}\}\})?.*?>|(\{\{\{variable:(.*?)\}\}\})"
test_str = (" <section id=\"services\">\n"
" <div class=\"container\">\n"
" <div class=\"row\">\n"
" <div class=\"col-md-12\">\n"
" <p>You are using system version: {{{variable:system_version}}}</p>\n"
" <p>Your address: {{{variable:contact-email-address}}}</p>\n"
" <form action=\"http://k.loc/content/view/welcome\" class=\"default-form\" enctype=\"multipart/form-data\" method=\"post\" accept-charset=\"utf-8\">\n"
" <input type=\"hidden\" name=\"csrfkcmstoken\" value=\"94ee71ada809b9a79d1b723c81020c78\" />\n\n"
" <div class=\"row\">\n"
" <div class=\"col-sm-12 form-error\"></div>\n"
" </div>\n"
" <div class=\"row\"><div class=\"col-sm-12\"><fieldset id=\"personalinfo\"><legend>Personal information</legend><div class=\"row\"><div class=\"col-sm-12\">\n"
" <div class=\"control-label\">\n"
" <label for=\"testinput\">Name<span class=\"form-validation-required\"> * </span></label>\n\n"
" </div>\n"
" <div class=\"hint-text\">Enter at least 2 characters and a maximum of 12 characters.</div><input id=\"testinput\" name=\"testinput\" placeholder=\"Enter your name here.\" class=\"input-group width-50\" type=\"text\" value=\"{{{variable:system_name}}} {{{variable:system_login}}}\"><div class=\"row\"><div class=\"col-sm-12\"><div class=\"form-error\"></div></div></div></div></div><div class=\"row\"><div class=\"col-sm-12\">\n"
" <div class=\"control-label\">\n"
" <label for=\"testpassword\">Password</label>\n\n"
" </div>\n"
" <div class=\"hint-text\">Your password must be at least 12 characters long, contain 1 special character, 1 nunber, 1 lower case character and 1 upper case character.</div><input id=\"testpassword\" name=\"testpassword\" placeholder=\"Enter your password here.\" class=\"input-group width-50\" type=\"password\"><div class=\"row\"><div class=\"col-sm-12\"><div class=\"form-error\"></div></div></div></div></div></fieldset></div></div><div class=\"row\"><div class=\"col-sm-12\"><fieldset id=\"bioinfo\"><legend>Biographical information</legend><div class=\"row\"><div class=\"col-sm-12\">\n"
" <div class=\"control-label\">\n"
" <label for=\"testtextarea\">Biography</label>\n"
" <span class=\"hint-text\">A minimum of 40 characters and a maximum of 255 is allowed. This hint is displayed inline.</span>\n"
" </div>\n"
" <textarea id=\"testtextarea\" name=\"testtextarea\" placeholder=\"Please enter your biography here.\" class=\"input-group-wide width-100\" rows=\"5\" cols=\"80\">{{{variable:system_name}}}\n\n"
"{{{variable:system_login}}}</textarea><div class=\"row\"><div class=\"col-sm-12\"><div class=\"form-error\"></div></div></div></div></div><div class=\"row\"><div class=\"col-sm-12\">\n"
" <div class=\"control-label\">\n"
" <label for=\"testsummernote\">Interests</label>\n"
" <span class=\"hint-text\">A minimum of 40 characters is required. This hint is displayed inline.</span>\n"
" </div>\n"
" <textarea id=\"testsummernote\" name=\"testsummernote\" class=\"wysiwyg-editor\" placeholder=\"Please enter your interests here.\"><p>{{{variable:system_name}}}<br></p><p>{{{variable:system_login}}}</p><p>{{{variable:activate_url}}}<br></p></textarea></div></div></fieldset></div></div><div class=\"row\"><div class=\"col-sm-12\"><button name=\"testsubmit\" id=\"testsubmit\" type=\"submit\" class=\"btn primary\">Submit<i class=\"zmdi zmdi-arrow-forward\"></i></button></div></div>\n"
" </form> </div>\n")
matches = re.finditer(regex, test_str, re.IGNORECASE | re.DOTALL)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.