$re = '/^(([^<>()[\]\\\\.,;:@"]+(\.[^<>()[\]\\\\.,;:@"]+)*)|(".+"))@((\[[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\.[0-9]{1,3}\])|(([a-zA-Z\-0-9]+\.)+[a-zA-Z]{2,}))$/m';
$str = 'test@example.com
test.example.com
test@example"));
test@.com
test@exa_mple.com
test@exa-mple.co
test@exa.mple.com';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);