$re = '/(((([[:digit:]]{4})-([[:digit:]]{2})-([[:digit:]]{2})|([[:digit:]]{2})-([[:digit:]]{2})|([[:digit:]]{2}))(_?))+)(\s(.+))?/m';
$str = '2023-06-25 DVD
2024-07-14_15
2024-06-09_09
2018-05-01 VOD Orange
2024-08-25_26 Disney+
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);