package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(((([[:digit:]]{4})-([[:digit:]]{2})-([[:digit:]]{2})|([[:digit:]]{2})-([[:digit:]]{2})|([[:digit:]]{2}))(_?))+)(\s(.+))?`)
var str = `2024-08-25_25_2023_11_13 Disney+
2024-07-14_15
2023-06-25 DVD
2024-06-09_09
2018-05-01 VOD Orange
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}