re = /^(\d{1,4}|[1-5]\d{4}|6[0-4]\d{3}|65[0-4]\d{2}|655[0-2]\d|6553[0-5])(?:,\g<1>)*$/mx
str = '1
12
123
1234
12345
9999
65535
0,1,65,6553
65535,-1,25
65536
123456
99999'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end