package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^the|cat$`)
var str = `the little cat
the small cat`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}