$re = '/<p.*?>(.*?)<\/p>/m';
$str = '<i> test</i>
<p>x</p>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);