package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^Mali-([\w]+)(-[\w]+)?`)
var str = `Mali-Version-EXTRA_CRAP
Mali-VERSION
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}