const regex = /<drupal-entity((?!<drupal-entity).)*?><\/drupal-entity><p> <\/p>/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<drupal-entity((?!<drupal-entity).)*?><\\\/drupal-entity><p> <\\\/p>', 'g')
const str = `</p><drupal-entity data-view-mode="oembed_display"></drupal-entity><p><strong>Designer Crush:</strong></p><drupal-entity data-view-mode="oembed_display"></drupal-entity><p> </p>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}