$re = '/".+?"/m';
$str = '"the little cat " is a toy,it looks "a little bad".';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);