$re = '/^(?=.*[A-Za-z])(?=.*\d)[A-Za-z\d!$%@#£€*?&]/m';
$str = 'Test1234*';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);