$re = '/.(?=.{4})/m';
$str = 'asdfaslcvbieubcasku';
$subst = "x";
$result = preg_replace($re, $subst, $str);
echo "The result of the substitution is ".$result;