const regex = /(?(DEFINE)(?<F>(?<c>\w)(?=(?!\w*?(?P=c))\w*+\h++\w*?(?P=c)|(?>\w*?(?P=c)(?=\w*+\h++\w*?(?P=c)(*COMMIT)(\g{-1}?+\w*?(?P=c))))+)))\b(?=(\w(?:(?-1)|\h++)\w)\b)(?&F)++\b/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?(DEFINE)(?<F>(?<c>\\w)(?=(?!\\w*?(?P=c))\\w*+\\h++\\w*?(?P=c)|(?>\\w*?(?P=c)(?=\\w*+\\h++\\w*?(?P=c)(*COMMIT)(\\g{-1}?+\\w*?(?P=c))))+)))\\b(?=(\\w(?:(?-1)|\\h++)\\w)\\b)(?&F)++\\b', 'g')
const str = `fourth thourf very veery vry very veryy rsun urns a a this is not pann pout toop topo
now we go with smart trams maps amps because declamations anecdotalism
reoccupation cornucopiate
aaab bbba abab babb
aaab bbba
abab abbb
bbaa bbba
bbaa abab`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}