const regex = /(\d*\.?\d+)(?:g|\(g(?:\/\d*ml)?\)|(?:,\s+|$))/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d*\\.?\\d+)(?:g|\\(g(?:\\\/\\d*ml)?\\)|(?:,\\s+|$))', 'gm')
const str = `0, 1, 0.1, .1, 1g, 0.1g, .1g, 1(g/100ml), .1(g/ml), .1, 0, 10(g), .1g, 1, 1.123`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}