const regex = /(?<ApplicationName>.+)\s(?<ApplicationId>[\w-]+)\s(?<ApplicationType>[\w-]+)\s(?<StartTime>\w{3}\s\w{3}[\d:\s]+[A-Z]+\s\d{4})\s(?<EndTime>\w{3}\s\w{3}[\d:\s]+[A-Z]+\s\d{4})\s(?<FinalState>[A-Z]+)\s(?<Queue>[^\s]+)\s((?<QueueUtilization>[^\s]+)\s)?\w+$/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(?<ApplicationName>.+)\\s(?<ApplicationId>[\\w-]+)\\s(?<ApplicationType>[\\w-]+)\\s(?<StartTime>\\w{3}\\s\\w{3}[\\d:\\s]+[A-Z]+\\s\\d{4})\\s(?<EndTime>\\w{3}\\s\\w{3}[\\d:\\s]+[A-Z]+\\s\\d{4})\\s(?<FinalState>[A-Z]+)\\s(?<Queue>[^\\s]+)\\s((?<QueueUtilization>[^\\s]+)\\s)?\\w+$', 'gm')
const str = `Spark Python Pi-job application_1681357021637_0983 SPARK Wed May 3 04:32:02 MST 2023 Wed May 3 04:32:11 MST 2023 SUCCEEDED default Fine edmse2
Oozie Job on Vip 0306563-230428030149477-oozie-oozi-W Shell-Action Wed May 3 04:32:09 MST 2023 Wed May 3 04:32:17 MST 2023 SUCCEEDED default nemoqee2
Distcp job application_1681357021637_0984 MAPREDUCE Wed May 3 04:32:32 MST 2023 Wed May 3 04:32:40 MST 2023 SUCCEEDED default Fine edmse2`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}