# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/^(.*?sheet\/)pub(.*)(&[a-z=]*)$/$1ccc$2#gid=0/i;t' <<< "aaa/bbbbb/ccc.d:abcsheet/pub/more/here?aa=0&output=html"