package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)hate.*expressions`)
var str = `'I hate regular expressions',`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}