import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(?<=[\"']\\s*(SELECT)\\s*)(SELECT|FROM)";
final String string = "\"SELECT * FROM table\"\n"
+ "\"\n"
+ " SELECT * FROM table\"\n\n"
+ "\"\"\"\n"
+ "Use this query here: \"SELECT * FROM table\"\n"
+ "\"\"\"\n\n"
+ "SELECT * FROM table";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}