using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<=[\r\n])(.+)(?=[\r\n])";
string input = @"This patch requires:
Patch 1.10-1
Patch 1.11-2
Notes:";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}