re = /(\[[^]]+\])/m
str = '<p> Lorem ipsum dolor [State] sit amet, consectetur [City] adipisicing [TopJob7] elit, sed do eiusmod [JobType]</p>'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end