re = /^(?:\[\w+=(?<bracketword>\w+)\]|\#(?<word>\w+))$/m
str = '[name=anystring]
#anystring'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end