re = /(?:\$\()(.*?)(?:\))/
str = '$(123=tr@e:123)124rt12$(=ttre@tre)frg12<>$(rez45)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end