package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(1|2|3)(4|5|6)`)
var str = `124456`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}