$re = '/(?!(COM|СОМ))\d{11,19}/ui';
$str = 'А23123132323B 123 BBB123123123DDD СЧ 80060050044, COM231231231231 80060050044 BBB123123123DDD 333';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);