# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"^(?<track>https:\/\/soundcloud.com\/(?:(?!sets|stats|groups|upload|you|mobile|stream|messages|discover|notifications|terms-of-use|people|pages|jobs|settings|logout|charts|imprint|popular)(?:[a-z0-9\-_]{1,25}))\/(?:(?:(?!sets|playlist|stats|settings|logout|notifications|you|messages)(?:[a-z0-9\-_]{1,100}))(?:\/s\-[a-zA-Z0-9\-_]{1,10})?))(?:[a-z0-9\-\?=\/]*)$"
test_str = ("https://soundcloud.com/vatogonzalez/whiskey-riddim/s-sdfsdf\n"
"https://soundcloud.com/you/library\n"
"https://soundcloud.com/barongfamily\n"
"https://soundcloud.com/barongfamily/sets/family-matters-vol-5\n"
"https://soundcloud.com/howshugo/01-hugo-no-access/recommended\n"
"https://soundcloud.com/you/likes\n"
"https://soundcloud.com/howshugo/01-hugo-no-access?in=howshugo/sets/rhapsodia\n"
"https://soundcloud.com/upload\n"
"https://soundcloud.com/popular/searches\n"
"https://soundcloud.com/messages/188812368:647571876\n"
"https://soundcloud.com/dirtyhouseradio/stats")
matches = re.finditer(regex, test_str, re.MULTILINE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.