$re = '/TEST-TEXT(?=<\/a>)/m';
$str = '<div class="TEST-TEXT">hi</span><a href=\\"https://en.wikipedia.org/wiki/TEST-TEXT\\">first young CEO\'s
TEST-TEXT</a><span class="test">hello</span>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);