$re = '/My ranking : [\S\d]{20}/m';
$str = 'My ranking : sdRWEXHYKlQHxmUMrP2P';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);