$re = '/^(?=.*[a-z])(?=.*[A-Z])(?=.*\d)(?=.*[!$%&?@#\._-]).{8,10}$/';
$str = 'subjuliodesign@gmail.com';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);