package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)\b([a-zA-Z]+):`)
var str = `animal: cat -> ["animal"]
animal: (mountain lion) -> ["animal"]
month: february day: sunday -> ["month", "day"]
date: (july 31) weather: (blue sky) -> ["date", "weather"]`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}