$re = '/[^A-Z]/m';
$str = '[]内の^は否定の意味になる
ABC123
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);