$re = '/([A-Z]+)(?=(?:\s+\S+){3}\s*(\d+(?:\.\d+)?)(?:\s+\S+){3}\s+(\d+))/m';
$str = 'ABC FED GHK LMN 45.00 60.00 30.00 10.00 4 5 5 6';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);