re = /(([a-z_]+)[ ]*:=[ ]*)?'([^']*)'/m
str = 'unit Language.EN;
interface
uses
Winapi.Windows, System.SysUtils;
type
TDummyParent = record
private const
Languages: array [0 .. 2] of string = (\'German\', \'English\');
public
class var a, b, c, d: string;
class procedure DummyProcedure; static;
end;
implementation
class procedure TDummyParent.DummyProcedure;
begin
a := \'string-a\';
b := \'string-b\';
c := sLineBreak + \'string-d\';
d :=
\'1 2 3 \' +
\'4 5 6 \' +
\'7 8 9\';
end; '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end