$re = '/^(?:.(?=.+?(.\1?$)))*?(^..?$|..?(?=\1$))/m';
$str = 'Hello
world
merged
hi
I
a
ab
abc
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);