$re = '/[\n\r].*Owner:\s*((?!\\\\n\\\\n).)*/m';
$str = '{
"description": "This project contains the code, pipelines and artifacts for the (ProjectName) project. \\nOwner: (OwnerName)\\n\\nDetails: (ProjectDetails)
}';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);