import re
regex = re.compile(r"^[A-Z]+-\d+,.*(?:\n(?![A-Z]+-\d+,).*)*", flags=re.MULTILINE)
test_str = ("ABC-1,01/01/1974,X1,Y1,Z1,\"RANDOM SINLGE LINE TEXT 1\",\n"
"ABC-2,01/01/1974,X2,Y2,Z2,\"THIS IS\n"
"A RANDOM\n\n"
"MULTI LINE\n"
"TEXT 2\",\n"
"ABC-3,01/01/1974,X3,Y3,Z3,\"THIS IS\n\n"
"ANOTHER RANDOM\n"
"MULTI LINE TEXT\",")
matches = regex.finditer(test_str)
for match_num, match in enumerate(matches, start=1):
print(f"Match {match_num} was found at {match.start()}-{match.end()}: {match.group()}")
for group_num, group in enumerate(match.groups(), start=1):
print(f"Group {group_num} found at {match.start(group_num)}-{match.end(group_num)}: {group}")