$re = '/(?<=")[^"=]+(?=")|[^,=" ]+/m';
$str = 'val="a,b", kind="Bax", priority=33,foo=bar, name="John Doe", lorem=ipsum';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);