re = /(?:[\s\S]*^——$|\G(?!^))\R\K.+/m
str = 'TITLE
——
1 nuit
1 nuit
1 nuit
1 nuit
1 nuit
total : 5 nuits
——
1 nuit
1 nuit
1 nuit
total : 3 nuits
——
1 nuit
1 nuit
1 nuit
1 nuit
1 nuit
1 nuit'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end