re = /[^aeiouy]*[aeiouy]+(?:[^aeiouy]*$|[^aeiouy](?=[^aeiouy]))?/i
str = 'experimental'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end