// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r#"<([\w\-\/]+)( +[\w\-]+(=(('[^']*')|("[^"]*")))?)* *>"#).unwrap();
let string = " </div><!-- SectionHeaderWrapper --><div id=\"SectionContent\"><h3 id=\"sAdministrativeDataSummary\" class=\"mDisabled\">Administrative data</h3><h3 id=\"sWorkersHazardViaInhalationRoute\">Workers - Hazard via inhalation route</h3><h4>Systemic effects</h4><h5>Long term exposure</h5><dl class=\"HorDL\"><dt>Hazard assessment conclusion:</dt><dd>no hazard identified</dd></dl></dl></dl></dl></dl></dl><h5>Acute/short term exposure</h5><dl class=\"HorDL\"><dt>Hazard assessment conclusion:</dt><dd>no hazard identified</dd></dl><h6>DNEL related information</h6></dl></dl></dl></dl></dl><h4>Local effects</h4><h5>Long term exposure</h5><dl class=\"HorDL\"><dt>Hazard assessment conclusion:</dt><dd>DNEL (Derived No Effect Level)
Value:</dt><dd><span class=\"UserEntry\">0.02</span> mg/m³
Most sensitive endpoint:</dt><dd>repeated dose toxicity</dd></dl><h6>DNEL related information</h6><dl class=\"HorDL\"><dt>DNEL derivation method:</dt><dd>other: <span class=\"UserEntry\">Biocidal Products Regulation guidance for Human Health Risk Assessment (Volume III, Part B, December 2013</span>";
let substitution = "\\n";
// result will be a String with the substituted value
let result = regex.replace_all(string, substitution);
println!("{}", result);
}