#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)from company.*?\K\d+"
Local $sString = "This is invoice from company XYZ - 1234545 product name , product number 444456, information invoice unit cost $12.0 and invoice total $1343.00" & @CRLF & _
"" & @CRLF & _
"This is invoice from company ABC - 1234545 product name and information invoice total cost $6777 and invoice unit cost $654"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")