$re = '/([a-zA-Z0-9.!$%&+=?^`{|}_-]?)(@here)+([a-zA-Z0-9.!$%&+=?^`{|}_-]?)(?=\b)(?!(@[a-zA-Z0-9-]+?(\.[a-zA-Z]+)+)|((?:(?!<a).)+)?<\/a>|[^<]*(<\/pre>|<\/code>))/m';
$str = '@here@here @here
hi @here';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);