$re = '/(?<!^\D)\d+.*/m';
$str = 'B9966
ch6258
028
chIRZ170
IRZ170
B8966A';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);