$re = '/[a-zA-Z0-9@#$]{8,50}/m';
$str = 'AAAAAAAA';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);